Raspberry Pi4 - Openplotter- Sortie GPS

Bonjour à tous
Ayant du temps a cause du covid, je me suis lancé grace à
la chaine youtube de Ralph:


que je remercie au passage,
dans la conception d'une centrale de nav a base d'un Rpi4 avec OpenPlotter comprenant signal K, Opencpn etc...
Alors, pour le moment j'ai réussi connecter un Gps Usb, a installer un capteur de température BME280, un gyroscope MPU 9250.
J'ai également configuré l'entrée AIS de ma Vhf RT-550.
Mais voila, maintenant je souhaiterai configurer une sortie Gps pour renvoyer les données Gps à ma Vhf.
Et ultérieurement connecter mes équipements St60 (vent, lock et speedo) ainsi que mon pilote auto St6000 tout ce petit monde en nmea 0183.
Mais bon, l'important étant pour le moment la sortie Gps car après toutes mes recherches les infos ou les tutos sont très majoritairements en anglais.
J'ai également regardé la section: recherche du site, mais sans réels infos concernant mon problème.
merci d'avance
Fred

L'équipage
22 mar. 2021
22 mar. 2021
0

Bonsoir
Aie!!!
je ne pensais pas que ma question était compliquée a ce point, pas un spécialiste de la framboise aujourd'hui😢
Fred


22 mar. 2021
0

salut Jdmuys
Merci pour le Up.
Mais, en regardant ta mini bio je me dis que tu aurais pu trouver mieux pour aider, moi ou d'autre membres du forum.
Mais, merci quand même...
Fred


22 mar. 202122 mar. 2021
0

Ben c'est surtout que je n'ai pas compris ton problème. Ma suggestion est de dire:

  • que veux tu faire exactement
  • qu'as tu tenté
  • qu'a été le résultat
  • en quoi le résultat différait-il de tes attentes

Pour terminer, je n'ai que très peu d'expérience avec le Raspberry Pi, et je crains ne pas avoir de réponse pour toi.

Et voyant que ton lien YouTube ne fonctionnait pas, tu aurais pu le reformatter comme ceci:


22 mar. 202122 mar. 2021
0

pas très bien compris le besoin non plus mais une solution par ici peut être?
(pareil, je suis tout débutant en Rpi, j'ai tout juste installé Open Plotter et Muxberry)
www.hisse-et-oh.com[...]spberry


22 mar. 202122 mar. 2021
0

Ok, je vais donc essayer de reformuler.
J'ai connecté un Gps Usb a OpenPlotter et signalK et tout fonctionne bien.
Maintenant, je souhaiterai envoyer ces données a ma Vhf.
J'ai cru comprendre qu'il fallait que je crée via signal K et Opencpn une connexion en sortie, mais après de nombreux essais je n'y arrive pas.
Voila, j'espère avoir été plus clair.
Fred


23 mar. 2021
0

Quelle ton interface hardware? (matériel, plan/schéma de connexion...)
Que veux tu dire par je n'y arrive pas? que constates tu? quels essais as tu fait?


23 mar. 2021
0

Salut Fred,

J'ai ce genre de connexion sur mon OpenPlotter.

J'utilise un adaptateur USB->série quelconque, et j'ai soudé les deux fils TX et GND du connecteur RS232 vers l'entrée de la VHF (NMEA+ / NMEA-). Ca c'est pour la partie hardware.

Du côté, soft, tout d'abord dans "OpenPlotter serial", tu devrais voir ton adaptateur USB->série, tu lui donne un nom (moi je l'ai appelé vhf, ce qui fait /dev/ttyOP_vhf), et tu le configure en tant que NMEA0183. Pas de connexion à définir à ce niveau là.

Il faut que le paquet openplotter-kplex soit installé, sinon tu l'installes en passant par OpenPlotter Settings.

Ensuite, dans "OpenPlotter kplex", tu ajoutes un device: type série, nom ttyOP_vhf, vitesse 4800 (ou autre, en fonction de ce que ta VHF peut accepter), mode out. De plus, moi je filtre pour envoyer juste les trames GPS à ma VHF, donc je met un "out filter", "accept only", "GP*** GN*** GA*** GL***"

Dernière chose, mais je pense qu'elle est automatique, tu peux aller dans Signalk, tu te logues, puis Server, Data Connections, et vérifier qu'il y a bien une connexion vers kplex.

Après tu as d'autres façons d'y faire, sans passer par kplex, mais en passant directement par OpenCPN (mais là ça suppose que OpenCPN tourne tout le temps...), et peut-être même une solution purement SignalK sans kplex, mais j'ai jamais testé.


23 mar. 2021
0

Bonjour à tous
Un grand merci à vous deux pour vos réponses.
Je vais essayer de passer au bateau cet après-midi et je reviens vers vous.
A+
Fred


23 mar. 2021
0

Bonsoir Stelian
Je n'ai pas eu le temps de tester aujourd'hui.
Je devrais y passer demain
Merci encore
A demain
Fred


23 mar. 2021
0

Bonsoir Stelian
Je n'ai pas eu le temps de tester aujourd'hui.
Je devrais y passer demain
Merci encore
A demain
Fred


24 mar. 2021
0

Bonsoir a tous
Alors suite a mon passage au bateau, le problème perdure 😢

Suite aux indications de Stelian ci-dessous:

J'utilise un adaptateur USB->série quelconque, et j'ai soudé les deux fils TX et GND du connecteur RS232 vers l'entrée de la VHF (NMEA+ / NMEA-). Ca c'est pour la partie hardware.
Du côté, soft, tout d'abord dans "OpenPlotter serial", tu devrais voir ton adaptateur USB->série, tu lui donne un nom (moi je l'ai appelé vhf, ce qui fait /dev/ttyOP
vhf), et tu le configure en tant que NMEA0183. Pas de connexion à définir à ce niveau là.
Il faut que le paquet openplotter-kplex soit installé, sinon tu l'installes en passant par OpenPlotter Settings.
Ensuite, dans "OpenPlotter kplex", tu ajoutes un device: type série, nom ttyOP_vhf, vitesse 4800 (ou autre, en fonction de ce que ta VHF peut accepter), mode out. _

jusque là tout va bien.

Mais a partir de là, ça deconne 😢
Je m'explique:
_De plus, moi je filtre pour envoyer juste les trames GPS à ma VHF, donc je met un "out filter", "accept only", "GP* GN*** GA*** GL**"_*
Pour moi, impossible de filtrer les données Photo 1
J'ai essayé de saisir GP*** dans la case ou se trouve les *** et ensuite d'appuyer sur: "Add sentence"
réponse: "vous devez saisir trois lettres majuscules" 🥴 J'ai essayé, mais réponse identique 😮
je me suis dis: pas grave avance…
La suite:
_Dernière chose, mais je pense qu'elle est automatique, tu peux aller dans Signalk, tu te logues, puis Server, Data Connections, et vérifier qu'il y a bien une connexion vers kplex.
_

Pour moi pas de connexion SignalK vers kplex 🙄
Pourtant kplex est bien installé: photo 3
J'ai bien essayé de désinstallé kplex et de le ré-installé= rien,
pas de trace d'une connexion SignalK vers kplex ou inversement…
J'ai alors tâtonné et essayé de créer une connexion dans signalK
Exemple: nmea 0183 vers dev/ttyOP_vouthf = rien
La meme manip avec une connexion en out dans OpenCpn = rien
plus tout un tas de manipes qui n'on rien donnés également.
Voila le résultat de l'après midi, j'espère avoir été à peu près clair 🥺
Si quelqu'un a une idée.
Merci d'avance
Fred


24 mar. 202124 mar. 2021
0

Pour le filtre: tu mets GP dans la case où il y a deux étoiles, et tu laisses les trois étoiles telles quelles, et tu fais Add sentence, ça va rajouter:
GP***

Ta photo2 est illisible, et il n'y a pas de photo3

Je vais te faire des copies d'écran tout à l'heure.

Mais, est-ce que tu es certain que tu as utilisé les bons pins du connecteur RS232 (et les bons fils de ta VHF). Car si c'est pas bon à ce niveau tu ne verras rien du tout... Pour débugger, et si tu as un câble/adaptateur null-modem, je brancherais un deuxième PC avec un soft de terminal (hyperterminal sous Windows, minicom sous Linux) de l'autre côté pour voir si c'est bien transmis. Ou un oscillo mais là ça va un peu loin...


Nexus:Salut StelianMerci de ta réponseConcernant le filtre il me semble avoir fait cela, mais je n'en suis pas complètement sur (je retesterai demain).Aie désolé pour la photo mais c'était juste pour démontrer l'installation de Kplex.et concernant le connecteur RS232, j'ai installé celui-ci : www.amazon.fr[...]o06_s00 qui fonctionne très bien sur mon entrée AIS.Mais bon, le fait de ne meme pas voir une connexion SignalK vers Kplex est pour le moins ennuyeuse.Ok pour les copies, MerciFred·le 24 mar. 20:21
stelian:Si ton adaptateur RS232 fonctionne c'est bon, j'espère juste que tu as bien changé de pin: pour ton AIS c'était le RX que tu utilisais, alors que là c'est le TX qui va aller vers ta VHF...·le 24 mar. 21:01
Nexus:Oui, c'est bien monté comme ça, mais merci qu'en même 😉·le 24 mar. 21:18
24 mar. 2021
0

Et voilà à quoi ressemble mes settings de kplex et de signalk.

Je suis par contre quasiment certain que je n'ai pas rajouté à la main la config dans signalk.

C'est peut-être quand on rajoute le put_sk dans kplex que ça crée l'autre... A tester.

Aussi, est-ce que tu peux vérifier que kplex tourne bien ? (ps aux | grep kplex) Je me souviens qu'il y a bien longtemps il y avait un bug dans le script de lancement de kplex, mais ça a du être corrigé je pense depuis.

Chez moi:

pi@pasiphae:~ $ ps aux |grep kplex
root 545 0.1 0.0 26744 92 ? Ssl mars23 4:26 /usr/bin/kplex -f /home/pi/.kplex.conf -p /var/run/kplex.pid -o mode background
pi 12926 0.5 3.2 159920 62316 ? Sl 20:56 0:02 /usr/bin/python3 /usr/bin/openplotter-kplex
pi 13687 0.0 0.0 7364 572 pts/0 S+ 21:03 0:00 grep --color=auto kplex


Nexus:Ok, merci pour tes captures d'écran.Mais je remarque que toutes tes connexions "passent" par Kplex, alors que moi tout passe par SignalK .Et, je remarque sur ta seconde capture que le port est: 50.000. c'est bien cela?·le 24 mar. 21:27
stelian:Oui, ça correspond au port 50000 de put_sk de la première capture.·le 24 mar. 21:41
Nexus:Ah oui, je commence à découvrir Kplex. Je buche, je buche. Merci ·le 24 mar. 21:57
25 mar. 2021
0

Bonjour à tous,
sortie GPS le retour.
Pour commencer ce matin j'ai enfin réussi à rentrer les filtres comme l'a expliqué Stelian, je m'obstinais à vouloir saisir les étoiles.
Enfin une avancée positive.
La mauvaise nouvelle est que je n'ai pas encore réussi à configurer une connexion avec signal K.
Je pense, que cela peut venir du fait que je n'ai pas réussi à créer la connexion Kplex vers SignalK.
Mais je ne désespère pas je vais creuser dans cette direction.
A+
Fred


25 mar. 2021
0

Euh tu ouvres kplex, puis "add", puis "putsk example", puis ok
puis à nouveau "add", puis "get
sk example", puis ok

En fait mon exemple est un peu différent de ta situation, car, au lieu de mettre le GPS directement dans signalk, je le mets dans gpsd, et j'utilise kplex (gpsd) pour lire le GPS, puis kplex (put_sk) pour envoyer les données à signalk. Du coup kplex dispose des données GPS et peut les envoyer directement à la VHF. La raison pour laquelle j'ai fait ça c'est parce que j'ai développé un petit programme qui loggue la trace en permanence, et ce programme passe par gpsd, donc j'ai besoin de gpsd. Comme ça j'ai une sauvegarde de la trace sans passer par signalk (il parait que c'est aussi possible, mais pas eu le temps de regarder, j'avais juste trouvé comment logguer les datas brutes, or pour un GPS il faut logguer uniquement lorsque les points sont différents, sinon on va remplir la carte SD)

Dans ton cas, si tu as configuré comme la plupart des gens le GPS pour qu'il aille directement dans signalk, et ben il te faudra dans kplex configurer la règle "getsk" pour prendre ces données. "putsk" ne sera utile que si tu utilises kplex pour lire l'ais (là encore tu peux l'interfacer directement avec signalk à la place).

J'espère que c'est clair...


Nexus:Salut StelianMerci de ta réponse, oui, c'est clair, tu as parfaitement raisonc'est également le résultat de ma réflexion, je penses comme je l'ai indiqué dans mon précédent post creuser dans cette direction.je vais encore essayer cet après midi via kplex et en cas d'échec, j'essaierai un autre chemin.Encore une fois merci pour ton aide.A+Fred·le 25 mar. 11:15
25 mar. 2021
0

rien à ajouter aux conseils de Stelian sur le HW
petit hors sujet, je viens de trouver : www.hisse-et-oh.com[...]ttl-usb


Nexus:Salut YannMerci pour le lien.Petite question: que veut dire "HW" 🙄MerciFred·le 25 mar. 20:51
25 mar. 2021
0

HW = hardware = matériel en français
SW = software = logiciel en français


Nexus:😁 OKMerci·le 26 mar. 07:50
yannbis:désolé pour l'usage abusif d'acronymes ;-)·le 26 mar. 22:30
0

Bonjour a tous
Bon, j'ai enfin pu aller sur le bateau pour essayer les différentes options d'écrites au dessus.
Et bien, malheureusement pas d'avancé, rien ne fonctionne🙄
Je pense que le fait que toutes mes connexions "passent" par Signal K et non par Kplex donne ce résultat.
Mon entrée GPS est configurée via GPSD, et fonctionne parfaitement et est bien visible dans Signal K.
Et dans la doc d'OpenPlotter disponible ici: openplotter.readthedocs.io[...]st/pdf/
la seule manip (que j'ai vu) détaillant une sortie nmea 0183 ne concerne qu'une sortie pour le pilote Auto.
Alors, j'ai bien essayé de me servir de cette "base" pour créer ma sortie GPS, mais sans succès.
Voila le résultat après cette sortie de confinement...
Si quelqu'un avait une idée, je lui en serai estivalement reconnaissant.
Fred


Votre réponse

Merci de contribuer aux réponses sur HISSE ET OH !

Merci de vérifier de bien répondre au sujet. Fournisser des détails sur votre réponse et partager votre expérience et vos recherches !

Mais éviter de …

  • Demander de l'aide ou de répondre à une autre question (utiliser les commentaires dans ce cas).
  • Porter un jugement et manquer de respect dans votre réponse.
  • Pour plus d'information, consulter la FAQ et la Charte de HISSE ET OH !

Déposer un fichier ici ou Cliquer pour envoyer

Les Cabanes de Fleury : l'orage est à terre

Après la pluie...

  • 4.5 (139)

Les Cabanes de Fleury : l'orage est à terre

mars 2021