Openplotter v2.0.0 du 13 01 2020

Bonjour,
Est ce que quelqu'un a déjà installé cette version sur un PI3?
Chez moi je n'y arrive pas, donc pour l'instant je suis toujours avec la version 1.1.0

L'équipage
16 fév. 2020
17 fév. 2020
1

Bonsoir,
Oui la semaine passée sur un Rpi3b+, 2 manières validées soit en passant par la version Noobs d’openplotter soit en chargeant Raspail bustier dans un premier temps puis openplotter expliquer ici : forum.openmarine.net[...]ead.php

17 fév. 2020
0

Bonjour Jipol,
Je n'ai pas réussi a mettre la version Noobs sur ma carte SD, j'ai dézippé le fichier et après comment il faut faire? cat je me retrouve avec un dossier et des tas de fichiers dedans...
Merci pour ton aide.

17 fév. 2020
0

Tu dézip sur ton ordi, au préalable tu auras formaté grâce au programme  »sd card formater » ta Sdcard’ et tu copies tous les fichiers dézipés sur ta sdcard ( attention les fichiers pas le répertoire ), puis tu mets ta carte dans ton pi et tu l’allumes l’installation se fait en cherchant sur Google et sur heo tu trouveras touts les détails

18 fév. 2020
0

Bonjour Jipol,
Lors de mes premiers essais j'avais bien formaté ma carte avec "SD Card Formater" et ensuite avec "Win32DiskImager" j'avais installé '2020-01-13-OpenPlotter-Starting-v2.0.img", mais après allumé mon RPI PI3 il ne se passe rien.
Donc je viens de faire comme tu me l'as indiqué mais là je bloque avec une carte SD de 32Gb qui après formatage ne dispose que de 29.7Gb donc insuffisante pour les 30.8Gb requis par Noobs pour coller l'ensemble des fichiers.
Tu utilise quel taille de carte SD?

18 fév. 2020
0

même problème que rigolad73 : pas de démarrage avec noobs.
par contre la version 1.2 open plotter marche très bien !

26 fév. 2020
0

Également des pbs avec openplotter v2 sur rasp 4 et 3b :
-vnc je n'arrive pas à le faire fonctionner
-bme 280 pas d'affichage
Par contre la version 1.2 marche très bien!

03 avr. 2020
0

Je viens d'installer la dernière version V2 du 24 mars 2020, mais je n'ai pas trouvé le mode d'emploi pour faire fonctionner mon GPS, l'AIS et mon capteur BMP280; Si quelqu'un peut m'expliquer comment faire pour le GPS et l'AIS ce serait un bon début...

03 avr. 2020
0

Bonjour Rigolad

Finalement tu as assez de place sur ta carte sd ?
Je vais faire l'installation aussi et j'avais en info qu'il faut une carte sd de 16go mini
J 'ai faut ou pas.

Le Moko

04 avr. 202016 juin 2020
-1

L'AIS n'est pas encore supporté sur OP 2.0

Pour le BMP280, il faut penser à activer l'I2C dans Préférences -> Configuration Raspberry PI -> Interfaces, puis paramétrer le capteur dans l'application openplotter I2C (voir captures écran)

Pour le GPS (je suppose USB) il suffit de l'activer dans l'application openplotter "Serial" : sélectionner le péripherique USB, lui donner comme nom par exemple "ttyOP_gps", et dans connections faire "Add to Signal K" (on peut aussi faire add to GPSD, mais dans ce cas il faut aussi installer et paramétrer KPLEX pour faire le lien entre gpsd et signal K)

VNC marche sans rien faire de particulier chez moi...

Pour la taille SD: il y a besoin d'environ 6 GB, mais si on rajoute des cartes on risque d'être un peu court avec 8 GB (mais ça marche: OP + cartes OpenCPN Oesenc FRA + GB ça tourne sur 8 GB mais disque plein à 97%)

05 avr. 2020
0

J'ai oublié de préciser ma config....
RPI3 carte micro SD 32Gb et j'ai installer opnplotter starting
Dans cette version en ouvrant le menu Openplotter je ne trouve pas le répertoire I2C qui permet d'afficher tes impressions écran, est ce normal et dans ce cas qu'elle est ta config. Sachant que je viens de commander un RPI 4

04 avr. 2020
0

Bonjour

@ Stelian effectivement avec ma 16gb il me reste de la place.
J 'ai installé sur deux cartes sd deux "versions" juste pour tester.
1) version open plotter V2 du 24/3/2020 pas de bol il me manque VNC
2) un desbian et ensuite le pack Open plotter . Beaucoup plus long à faire

Le Moko

05 avr. 2020
0

Bonjour Rigola

Attention je suis débutant.
J'ai un Pi 3 et selon je suis sur une sd 16gb et 32gb. j 'ai chargé la version OP starting.
L' autre version je ne sais pas pourquoi via noobs.3 j'ai chargé un Desbian et en suite les compléments OP, pas prévus mais je garde les deux et je découvre.

Le Moko

05 avr. 202005 avr. 2020
0

Alors pour ma config: j'ai une RPI3, et j'ai téléchargé la version 2020-03-24-starting (image standard pas noobs).

Pour l'application openplotter-i2c, il faut peut-être l'installer: soit en passant par le menu OpenPlotter -> Settings, faire "Refresh', sélectionner "I2C sensors" dans la liste déroulante, puis "Install". Et peut-être un reboot après.

On peut aussi le faire en ligne de commande: ouvrir un terminal (Accessoires-> Terminal), puis:

su

apt install openplotter-i2c

Pour VNC c'est vraiment étrange car moi je l'ai eu par défaut. J'ai l'icône en haut à droite de l'écran. Au pire, on peut l'installer par:

su

apt install realvnc-vnc-server

05 avr. 2020
0

je ne connais pas ce que tu me propose:
su

apt install openplotter-i2c
mais j'ai fais
sudo apt install openplotter-i2c
et cela fonctionne pour cette première étape.

05 avr. 2020
0

oui desolé c'est bien un sudo et non un su.

Si tu as bien installé le paquet openplotter-i2c tu devrais maintenant pouvoir faire le reste (lancement de l'appli i2c, ajout de BME280 etc)....

05 avr. 2020
0

(bizarre le formatage "code" ne semble pas marcher)

05 avr. 2020
0

Au cas où, il y a un autre fil au sujet de l'I2C sur OP: www.hisse-et-oh.com[...]plotter

05 avr. 2020
0

Merci Stelian pour ton aide :-)
Maintenant openplotter V2 fonctionne bien, mais j'aimerais faire la même chose sur SkipperOS 0.3
Donc j'ai fait apparaitre l'I2C dans le menu n écrivant la phrase
sudo apt install openplotter_i2c dans le terminal,
sur le même principe j'ai fais apparaitre Sére dans le menu
mais je ne connais pas la phrase exavt pour faire apparaitre :
Tableaux de Bords
Signal K
Installateur Signal K
Est ce que tu peux m'aider...
Merci

05 avr. 202005 avr. 2020
0

Alors je connais pas du tout skipperos.
(EDIT: j'ai cherché et je vois que c'est un OP + qtvlm, donc les instructions ci dessous devraient fonctionner)

Mais si c'est basée sur une openplotter (ou sur une raspbian ou autre dérivée d'ubuntu, tu peux tout simplement faire
sudo apt-cache search openplotter

Ca va te lister tous les paquets qui ont openplotter dans leur nom, et par exemple sur mon OP j'ai:

openplotter-mcs - This is a App for Openplotter 2.0 and higher to use with a GeDaD MarineControlServer Hardware
openplotter-can - OpenPlotter app to manage CAN BUS adapters
openplotter-dashboards - OpenPltter app to manage dashboards
openplotter-doc - OpenPlotter project documentation
openplotter-i2c - OpenPlotter app to manage I2C sensors in Raspberry Pi
openplotter-kplex - OpenPlotter app to manage NMEA 0183 data
openplotter-moitessier - OpenPlotter app to manage the Moitessier HAT
openplotter-network - OpenPlotter app to manage network connections in Raspberry Pi
openplotter-opencpn-installer - OpenPlotter app to manage OpenCPN installation
openplotter-pypilot - OpenPlotter app to integrate Pypilot in Raspberry Pi
openplotter-serial - OpenPlotter app to manage serial devices
openplotter-settings - Main OpenPlotter app
openplotter-signalk-installer - OpenPlotter app to manage Signal K node server installation
openplotter-skfilter - OpenPlotter app to filter Signal K Data

Il ne te reste plus qu'à faire le sudo apt install avec le nom du paquet....

08 avr. 2020
0

Bonjour,
je reviens sur l'installation de i2c sur openplotter V2.
Grace à tes conseils j'ai obtenu les 2 captures que tu présente.
Mais sur le dashboard la pression et la température n'apparait pas.
Pourrais tu éclairer ?
merci

08 avr. 2020
0

Tu as lu l'autre fil dont je donnais le lien plus haut, notamment la config du plugin "convert signal k to nmea0183" ?

08 avr. 2020
0

effet pbs réglé, pas bien lu

merci

05 avr. 2020
0

C'est génial, je vais tester maintenant, Merci.

08 avr. 2020
0

Bonsoir,
J'ai enfin pu installer cette nouvelle version, par contre je n'arrive pas à réinstaller le plug-in RTL-SDR.

09 avr. 202009 avr. 2020
2

Bonjour,
C'est moi qui est a l'origine de la distribution SKIPPER OS : voilier-oceane.com[...]per-os/
Sur la version 0.3, le SDR fonctionne avec les cles les plus connues.
Effectivement je suis partie d'une base raspbian et ajouté les packets Openplotter et quelques outils comme qtVlm, sdr-ais sdr-rtl, hamfax...
Sur la version 0.4, que je suis entrain de paramétrer, le capteur BM280 barometrique sera fonctionnel.

Je souhaite vous partager une distribution Francophone Plug and play.

Actuellement je travail avec un autre contributeur sur ce forum pour mettre en place un multiplexeur NMEA0183 + N2K et répétiteur distant.
Je galère a trouver comment lire les données AIS d'un dongle USB (avec sdr-ais en tcp sur localhost:10110) vers nmeaHub.
Cela marche deja si on bypass ce multiplexeur et que l'on fait une ecoute directement dans qtVlm ou bien OpenCPN.

Toute aide est la bienvenue ! :)
Benjamin

10 avr. 2020
2

Bonjour BenjiC34, je viens juste de me connecter sur le site...je vais rebrancher mon RPI et je regarde de plus près ou j'en suis de mon installation et je reviens ici pour informer la communauté sur mes difficultés.

Votre réponse

Merci de contribuer aux réponses sur HISSE ET OH !

Merci de vérifier de bien répondre au sujet. Fournisser des détails sur votre réponse et partager votre expérience et vos recherches !

Mais éviter de …

  • Demander de l'aide ou de répondre à une autre question (utiliser les commentaires dans ce cas).
  • Porter un jugement et manquer de respect dans votre réponse.
  • Pour plus d'information, consulter la FAQ et la Charte de HISSE ET OH !

Déposer un fichier ici ou Cliquer pour envoyer

Perdu à Paris

Après la pluie...

  • 4.5 (38)

Perdu à Paris

mars 2021