Interrupteur automatique: Transistor ou micro relais ?

Hello,
Question pour les électroniciens du bord:
Que dois-je faire comme montage pour fabriquer un interrupteur automatique ? Un micro-relais ou un transistor ?

J'ai un montage Arduino qui mesure plusieurs choses à bord et envoie les données sur le bus NMEA2000.
L'alimentation du montage se fait par le 12V du bus. Pas de pb de ce coté là, quand je quitte le bord et que je coupe l'alim des instruments, le montage n'est plus alimenté.

Par contre j'ai une petite fuite de courant de l'ordre de 0,1 à 0,2A du fait de la liaison série entre le contrôleur de batterie Victron BMV700 et le montage.
Comment faire pour que cette liaison se coupe quand il n'y a plus d'alim du montage ?

Le BMV700 est en liaison constante avec le shunt et est lui-même alimenté en permanence, même quand tous les coupes-circuits sont coupés. De ce coté, sa conso est très basse et ça ne me gène pas.

A coté de ça, la sortie data (TTL 3,3V) du BMV est reliée par un cable maison au montage Arduino.
C'est par cette liaison qui est non isolée que passe la fuite.
Pour info le cable officiel Victron BMV>USB est isolé par un Si8422 semble-il.
Je n'ai pas envie ni les capacités de refaire un câble Victron, aussi pour le moment, pour éviter cette petite fuite de courant quand tout est coupé, j'ai mis un simple inter à glissière.
Ca marche bien, mais ça m'est arriver d'oublier de le couper quand je quitte le bord.
Aussi je pensais le remplacer par un petit montage.
Ce petit montage couperait la liaison BMV>Arduino si l'Arduino n'était plus alimenté.
J'ai pensé commander cet interrupteur par le 5v de l'Arduino, soit avec un
- Transistor
- Micro-relais du type G5V-1 ( )

Le micro-relais consomme 30ma et je trouve cela trop important.
Par quel montage avec un transistor pourrais-je le remplacer ? (type de transsitor, résistance...)
Et ce dernier consommerait-il moins que 30ma ?

Pour mieux comprendre, voici un schéma grossier.
Le carré rouge avec un point d'interrogation est l'emplacement où mettre cet "interrupteur".
Je pense utiliser les +5V/GND disponibles sur l'Arduino pour activer cet inter.

Amicalement.
FX

L'équipage
29 juin 2021
29 juin 2021
0

Et si tu prenais un inter 6 broches pour couper en même temps l’alim de tes instruments et la liaison Arduino-BMV700 ?


fxvt:Hello,Non, ce ne serait pas pratique étant donné la configuration du tableau électrique. Ca m'obligerait à changer l'inter "instruments" du tableau et ajouterait des fils. au plat de spaghettis. Et je n'ai pas envie que le même inter manipule à la fois du 12v trivial et du 3,3v Data. Merci quand même pour cette idée. :-) Amicalement.FX·le 29 juin 12:19
Lulu2:Certes, mais les solutions simples sont souvent les meilleures. Cf les Shadocks 😊 ·le 29 juin 12:22
29 juin 202129 juin 2021
0

Une réponse très rapide après lecture en diagonale.
Si tu veux une conso vraiment à zero tu peux regarder les relais bistables.
Inconvénient : on ne connait pas leur état au repos, mais comme il y a un arduino dans ton montage, il peut piloter et contrôler l'état du bistable.

Avec un transistor ça fonctionne aussi.

Mais pour résoudre cet pb fuite , tu peux aussi mettre un optocoupleur qui isolera l'arduino du BMV.
certainement le plus propre.

La suggestion de Lulu est pertinente également! Très simple


fxvt:Hello Yannbis,Ah c'est là que j'ai besoin d'un coup de main.Comment fait-on un montage simple avec un transistor en commutation ? J'ai regardé ça un peu sur le net, mais j'hésite quant aux valeurs des composants.Bien sûr l'optocoupleur ce serait plus élégant, mais là un petit peu plus compliqué pour moi car j'imagine qu'un signal TTL ne se coupe pas aussi simplement.·le 29 juin 12:36
yannbis:Je ne comprends pas bien ou est le souci de couper un TTL (qui est juste un signal 0-5V, dans ton cas ce doit être un LVTTL à3.3V), avec un inter ça le fait très bien·le 29 juin 14:18
fxvt:Tu as raison, ce n'est pas un pb de couper cette liaison TTL si je ne veux pas que ça fuite quand on ne l'utilise pas.C'est ce que je fais déjà. J'ai mis un petit inter à glissière sur le montage.Ce que je ne veux pas c'est utilise un inter 6 broches pour les raisons que j'ai évoqué plus haut.Et ce que je veux c'est d'automatiser ce switchage.·le 29 juin 14:24
29 juin 2021
0

Curieux une fuite de 100 à 200 mA ??? C'est plus une fuite c'est une avalanche !
Il est connecté sur quoi sur l'arduino le bmv ?


fxvt:Le TTL TX du BMV est connecté sur le RX3 pin15 de l'Arduino Mega , plus GND sur une pin GND.C'est certain qu'un Arduino méga n'est donné que pour consommer 40mA à vide. Ca doit fuiter à travers l'Arduino et ça file ensuite par le réseau NMEA2000·le 29 juin 12:30
bepey:Si tu déconnectes tout ce qui est sur l'arduino à part rx3, gnd et le +alim du méga tu as toujours ta "fuite" ?·le 29 juin 20:01
29 juin 2021
0

Il y a des petits relais Panasonic qui consomment 50 mW (4.2 mA sous 12V).
docs.rs-online.com[...]fe5.pdf


29 juin 2021
0

Bonjour si tu souhaites utiliser un relai, ne prends pas un bi-stable qui pourrait commuter sur choque (dans le gros temps) et qui va t'imposer de faire un montage plus complexe pour le piloter.
A ta place, je choisirais un modèle à 2 voies afin de couper les 2 fils de la comm. Pour le pilotage du relais, alimente-le simplement avec l'alim de l'arduino. (Pas d'alim, pas de comm ni de couplage électrique)

Par contre 0,1 à 0,2 A c'est pas une petite fuite! es-tu sûr que c'est uniquement la comm avec le victron qui est en cause.

La solution la plus élégante serait de mettre une isolation galvanique sur le port de comm. C'est très facile avec un optocoupleur et quelques résistances en plus sa consomme très peut, ca prend moins de place qu'un relai et consomme moins. Pour résumer, que des avantages


fxvt:C'est bien la seule et unique liaison TTL BMV>Arduino qui fuite autant.J'ai récemment recalibré le zéro du BMV et j'ai ai profité pour bien me re-re-re-confirmer que c'était cette liaison qui merdait.Dés que je la débranche, hop je repasse bien à zéro de conso. Et si en fin de weekend j'oublie de manipuler le petit inter à glissière, je vois bien que la capacité de la batterie a bien chuté de qq Ah en une ou 2 semaine, et ce n'est pas l'autodécharge car sur cette AGM elle est très très faible. A l'inverse, si je n'oublie pas de couper BMV/Adruino, la charge de la batterie ne bouge pas en 1ou 2 semaines.·le 29 juin 14:12
29 juin 202129 juin 2021
0

Hello,

Si je comprends bien c'est un signal très faible courant que tu veux couper ?
Dans ce cas, un simple 2N2222 en commutation devrait faire l'affaire. Une résistance sur la base (au pif, 4,7k 1/4w ?) et l'émeteur à la masse, et tu as un petit interrupteur commandé par ton arduino.

Les montages se trouvent facilement sur le net


29 juin 2021
0

Hello Now,

Ah voilà, c'est un conseil de ce type là que je cherchais.
Merci Now !
Je viens de regarder avec un peu plus d'attention sur le net et j'ai fait un schéma rapido.
J'hésite sur la valeur de la résistance. Quelle doit être sa valeur optimale pour que le transistor puisse réagir mais ne pas consommer trop ?
Est-ce que ça peut fonctionner ?

Amicalement.
FX


Now:4,7k, je crois bien que c'est ce qu'on mets de base (lointains souvenirs) mais tu ne trouve pas l'info sur le net?, c'est un montage assez classique pour une commutation de faibles signaux.·le 29 juin 17:35
flooo11:ce montage est une très mauvaise idée. A ne pas utiliser donc·le 29 juin 19:20
fxvt:Hello flooo11,Merci pour ta remarque. Est-ce que tu peux développer un peu ou mieux, proposer une alternative concrète.AmicalementFX·le 29 juin 19:30
flooo11:En faisant ce montage tu te retrouve avec des potentiels flottant, ce qui peux poser des problèmes. voir détruire l'arduino ou le BMV. Je vais proposer un montage (ce soir si j'ai le temps). avec optocoupleur comme nommé dans un de mes précédents messages·le 29 juin 20:13
Now:Je ne faisais qu'indiquer comment faire une commutation avec un transistor, fx parle de faire un interrupteur commandé sans grand pouvoir de coupure, et le montage à transistor répond à ça, mais effectivement il faut vérifier que ça correspond au besoin avec le reste du schéma, je n'ai pas regardé dans le détail le sujet.·le 29 juin 20:23
29 juin 2021
3

Installe plutôt une isolation galvanique à l'entrée de ton port TTL 3.3V sur l'Arduino.

C'est incroyable que le port de sortie du Victron ne soit pas découplé par un optocoupleur. Pour limiter la consommation intrinsèque au minimum, ils ont créé la possibilité d'avoir une fuite presque 100 fois plus importante

Luis Vega qui a conçu les multiplexeurs Nmea2Wifi et Nmea4Wifi a conçu deux bons montages d'isolateur gavanique utilisés sur chaque entrée de ses multiplexeurs. C'est facile à faire. cela permet aussi d'améliorer la résistance aux transitoires électromagnétiques qui pourraientt avoir de graves conséquences sur un bateau en plantant certains appareils.

Le Nmea2Wifi utilise des optocoupleurs simples. Le Nmea4Wifi utilise des optocoupleurs doubles pour optimiser l'encombrement du circuit imprimé.

L'utilisation d'un de ses multiplexeur est aussi une bonne façon de relier différents instruments ou réseaux sans créer de boucle de courant.


matelot@19001:Bien d'accord avec toi Jean-Marc, néanmoins si Victron n'a pas mis d'optocoupleur dans le BMV700 c'est que cet optocoupleur est inclus dans le câble VEdirect-USB vendu pour cela. Il n'ont pas prévu les bricoleurs d'Arduino ! Mais le plus logique dans le cas de FX serait en effet de rajouter un optocoupleur plutôt que de couper la liaison.·le 29 juin 15:31
J-Marc:Je serai très surpris que le câble USB soit isolé galvaniquement. A ce jour, je ne connais pas de prise USB isolée galvaniquement. Il y a pour cela des boîtiers de la taille d'une petite savonnette.Les prises USB de qualité sont par contre équipées de bons circuits suppresseurs de surtensions.·le 29 juin 16:42
fxvt:Hello,Eh oui, vous avez raison, c'est bien un opto-couplage qu'il faudrait. Mais je ne suis pas bon en électronique, je préfère coder, bien que je sois aussi très mauvais en programmation :-(Je vais essayer le switch avec un transistor, même si c'est à l'arrach.
Je touche quand même du bois car je sais que cette liaison BMV à 3,3V sur un Arduino à 5V est très sale, mais pour l'instant elle fonctionne sans pb depuis qq années.Et je sais que le jour où j'aurais un pb je penserai à cet échange sur Hisse et Oh :-)Amicalement.FX·le 29 juin 17:06
matelot@19001:Hé bien Jean-Marc tu ne connais pas tout, j'ai un câble Victron ASS030530010 (VE.Direct to USB interface) qui a la prise type JST-PH 4 pins qui va dans le BMV 700 et il a un optocoupleur à l'intérieur ! Bien sûr ce n'est pas un simple câble et de toute façon pour convertir en USB il faut un peu d'électronique. Bon cela vaut tout de même 30 €.·le 29 juin 19:11
matelot@19001:@fxvt : avec un optocoupleur 6N139 ce ne sera pas beaucoup plus compliqué à réaliser qu'une coupure par transistor.·le 29 juin 19:26
fxvt:Je dois avoir ça dans ma caisse à outil. Je m'en étais servi pour interfacer la borne w de l'alternateur et un Arduino.Si tu as un schéma je suis preneur car mon pb est toujours le même, je "fais de l'électronique" comme on fait de la mécanique. Avec un marteau, de la pratique mais peu de bases théoriques. Jamais eu le temps de vraiment m'y mettre.Amicalement.FX·le 29 juin 19:33
matelot@19001:Et moi je suis ignorant en Arduino. C'est comment les entrées RX de l'Arduino ? Juste du TTL en 3,3 V ?·le 29 juin 19:51
matelot@19001:Avant cela j'essaierais quand même un truc simple - on ne sait jamais- : intercaler 2 ou 3 diodes en série avec l'entrée, pour ramener la tension autour de 3,3 V. Il y a peut-être un diode zener de protection qui absorbe tout ce courant.·le 29 juin 20:02
29 juin 202129 juin 2021
0

Il y a un relais avec contact sec intégré dans le bvm.
Il se programme en fonction de l'état de charge et d'autres trucs je crois, faudrait lire la doc !

Par ailleurs pour la fuite c'est ce qu'affiche le bvm ou c'est ce que tu mesures avec un amperemetre et où ?


29 juin 2021
0

Voilà le petit schéma:

L'avantage c'est que la communication est isolée par l'optocoupleur, donc plus de courant entre le BMV et l'arduino (que de la lumière !;-) ).

L'isolation est importante car la masse de l'arduino n'est pas forcément celle du BMV. Rappelez-vous que vous avez le shunt (qui est une résistance) qui sépare le - batterie et la masse. Ce qui du coup peut engendrer des circulations de courant (d'où fuite).

J'espère être clair dans mon propos.

Concernant les valeurs et références de composant, je n'ai pas communiqué d'élément volontairement, car pour le choix de l'optocoupleur, il faut connaitre la vitesse de transmission. Pour le choix des résistances, il faut connaitre les tensions et faire en fonction de l'optocoupleur.
Données manquantes :
vitesse de transmission optocoupleur (Baudrate).
tension transmission bmv: (5V, 3.3V ou autre)

La valeur de la résistance coté arduino n'est pas trop critique 4,7 kOhms devrais aller


Votre réponse

Merci de contribuer aux réponses sur HISSE ET OH !

Merci de vérifier de bien répondre au sujet. Fournisser des détails sur votre réponse et partager votre expérience et vos recherches !

Mais éviter de …

  • Demander de l'aide ou de répondre à une autre question (utiliser les commentaires dans ce cas).
  • Porter un jugement et manquer de respect dans votre réponse.
  • Pour plus d'information, consulter la FAQ et la Charte de HISSE ET OH !

Déposer un fichier ici ou Cliquer pour envoyer

Après la pluie en Patagonie

Après la pluie...

  • 4.5 (33)

Après la pluie en Patagonie

mars 2021