Tous les forums > HEO Clubs > opencpn sur Debian 9 ?
Missing
First 0

opencpn sur Debian 9 ?

Bonsoir,
je n'arrive pas à installer opencpn. Voici quelques erreurs relevées lors de l'install depuis le dépôt "Ubuntu" :

W: The repository 'http://ppa.launchpad.net/opencpn/opencpn/ubuntu cosmic Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Impossible de récupérer http://ppa.launchpad.net/opencpn/opencpn/ubuntu/dists/cosmic/main/binary-amd64/Packages 404 Not Found
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.

j'ai tout de même essayé ->

root@HP:/home/bob# apt-get install opencpn
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet opencpn n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « opencpn » n'a pas de version susceptible d'être installée

La manip est celle de tous les tutos.
Y a t-il un pb avec le depot open,cpn ?
OU est-ce Debian 9 qui pose un pb de compatibilité ?
En clair, qqn a t-il installé opencpn sur Debian 9 ? Je n'ai rien trouvé sur le Net.

Merci de vos lumières.

samedi 26 mai 2018 21:44

Liste des contributions

Avatar_gilletarom
Gilletarom

@ First 0 :

Sur le site d'OpenCPN.org, il est dit ceci :
- For Debian derivatives, you can use the same packages as for some Ubuntu releases.
Debian Oldstable (Wheezy) You can use the packages from the Ubuntu PPA.
The compatible Ubuntu Release is Lucid. Unfortunately we can't add new Lucid builds to the PPA anymore due to it being obsolete. If you need newer plugins, you may try to use Precise packages instead. (You will most likely also need to upgrade your libc6 to version 2.15 or newer, so please consider switching to Jessie completely.)
Debian Stable (Jessie) You can use the packages from the Ubuntu PPA mentioned above. The compatible Ubuntu Release is Trusty.

Les gens qui utilsent des raspberry pi, arrivent, assez facilement, à installer OCPN sur Raspbian qui est une version dérivée de Debian ....

Voir aussi, la page officielle sur Opencpn.org ici :
- https://opencpn.org/wiki/dokuwiki/doku.php?id=opencpn:opencpn_user_manual:getting_started:opencpn_installation:linux

Et je pense que ce dépot n'est pas approprié :
- The repository 'http://ppa.launchpad.net/opencpn/opencpn/ubuntu cosmic Release'

samedi 26 mai 2018 21:58 *** Message modifié par son auteur ***
Mafaldahugopratt
Pytheas54

ubuntu bionic seulement...
pas encore cosmic...

samedi 26 mai 2018 22:25
Alanpp_eyeinthesky
minas anor

j'ai une Debian 9 et OpenCpn 4.8 d'installé.

je n'ai pas trouvé de paquet à installer directement par ppa, j(ai utilisé une autre méthode :
la démarche est un peu compliquée, il faut télécharger les sources par exemple avec git et ensuite compiler le programme, une piste ici :

https://opencpn.org/wiki/dokuwiki/doku.php?id=opencpn:developer_manual:developer_guide:compiling_linux

auparavant il faut installer tout le nécessaire pour compiler un programme, buil-essential cmake ....

avec un peu de patience et un peu de pratique du système linux, on y arrive.

samedi 26 mai 2018 22:50
Mafaldahugopratt
Pytheas54

Même sur debian, on peut installer le ou les ppa nécessaires
voir
https://launchpad.net/%7Eopencpn/+archive/ubuntu/opencpn/+packages?batch=75&memo=225&start=225
et pour les versions beta
https://launchpad.net/~bdbcat/+archive/ubuntu/opencpn

PS Les instructions de Gilletarom sont un peu "vieilliottes"

samedi 26 mai 2018 23:21 *** Message modifié par son auteur ***
Avatar_gilletarom
Gilletarom

@Pytheas54 :

"PS Les instructions de Gilletarom sont un peu "vieilliottes""

1° Mais :
- Elles ne disent pas encore de bêtise
- Et durant cet hiver 2017/18, elles ont déjà bien progressé.
2° Grace à la "veille technologique", quelques bribes de mises à jour viennent juste d'être faites.

dimanche 27 mai 2018 10:50 *** Message modifié par son auteur ***
Missing
First 0

Bonjour,

merci pour toutes ces contributions.

1-j'ai bien utilisé le ppa opencpn/opencpn : la réponse postée est le résultat de la commande.

2-j'ai oublié de signaler que je suis en 32 bits (pour différentes raisons..), si comme je le pense maintenant, le soutien du 32 bits n'est plus assuré, il ne sert sans doute à rien de déchiffrer les messages d'erreur. Incidemment, Debian 9 ne serait pas en cause.

3 j'ai contourné le pb en chargeant une version en tar.gz. le seul souci, c'est qu'il me manque 3 paquets dont une libtinyxml. J'ai installé les trois paquets en question dans leur version actuelle, mais ils sont toujours considérés comme manquants.

Visiblement, il n'y a pas de compatibilité ascendante, et je n'ai pas trouvé trace des anciennes versions de ces paquets, en faisant
aptitude search
par exemple.

Je n'ai jamais été confronté à un tel pb, peut être sans solution ( ?).
Je vais m'y pencher cette semaine, sans oublier d'explorer la piste de minas anor à partir des sources.
Je vous tiens au courant.

dimanche 27 mai 2018 11:07
Missing
First 0

Bon,
j'ai installé Debian 9 sur un PC portable en 64 bits - J'ai fait les maj.
Impossible d'installer opencpn depuis le ppa répercuté en boucle par les tutos (Ubunutu): mêmes messages que précédemment.

J'ai essayé de compiler les sources selon la piste de minas anor, mais je me heurte à de (trop) nombreuses dépendances manquantes.

Finalemùent, j'ai fait une install sous windows (je suis en dual boot), où tout marche impeccablement... ce qui laisse un goùt amer.

Je vais tout de même persévérer, ayant d 'autres applis qui tournent sous Debian.

vendredi 01 juin 2018 22:14
Sao
bruno972

Quelle version de kernel as-tu ? Il me semble que debian 9 est avec la version 4.9 or bionic utilise une 4.13

samedi 02 juin 2018 04:05
Missing
First 0

Bonsoir

ma version est la 4 9 0 6

Si c'est bien là le souci pourquoi renvoyer vers un dépôt ubuntu ?

mercredi 06 juin 2018 20:36

Répondre

Pour participer aux forums, vous devez être inscrit et identifié

Vous identifier | Créer un compte matelot

Retour forums