Tous les forums > HEO Clubs > Cartes oCharts pour Raspberry-Openplotter
01jean01
JeanRCA

Cartes oCharts pour Raspberry-Openplotter

Bonjour,
Je suis en train d'essayer de configurer un système Openplotter sur un Raspberry PI3. C'est sympa, cela a l'air de fonctionner vraiment bien cette petite bête !

Je bute sur les cartes: comme je suis content des cartes oCharts pour windows, je voudrais les installer aussi sur le Raspberry, mais j'ai un pb de plugin: il est en version 1.0, et c'est la 1.6 qui est actuellement utilisée par oCharts.

Comment je fais la mise à jour?
Pour l'instant, je ne trouve qu'un pack de plugin pour Linux, et je ne suis pas trop sûr de vouloir l'installer.

Merci de votre aide.

dimanche 04 février 2018 20:16

Liste des contributions

Myst%c3%a9re_
BlackSails...

Bonsoir,
Coté cartes,
Les CM93 avec un peu de recherche sur le net...
http://pierre.lavergne1.free.fr/special_voileux/cartographie.html
Qqs raster existent également...
Le reste à créer soit même via SAS Planet...
Le plus beau reste à faire, courage

dimanche 04 février 2018 20:45
Avatar_gilletarom
1
Gilletarom

@JeanRCA

Ajouter le ppa dans le fichier /etc/apt/sources.list
Il faut ajouter cette ligne :
deb http://ppa.launchapad.net/opencpn:opencpn/ubuntu xenial main

Et sauvegarder le fichier. Pour cela, il faudra sans doute ajouter, au préalable, les droits d'écriture pour ce fichier dans le dossier pour l'utilisateur pi.

Puis :
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install opencpn

Pas totalement sur de moi, mais c'est ce que j'ai compris.

dimanche 04 février 2018 20:47
01jean01
JeanRCA

Merci Gilletarom,
Je suis tout nouveau avec le Raspberry.
Pour que je comprenne bien:Cette manip réinstalle OpenCPN, avec le pack de plugin mis à jour?
Il n'y a pas moyen de juste mettre à jour oeSenc?

dimanche 04 février 2018 21:05
Avatar_gilletarom
2
Gilletarom

Autant pour moi. Bien vu.

Il faut remplacer "sudo apt-get install opencpn", par :
sudo apt-get install opencpn-plugin-ZZZZZ

dimanche 04 février 2018 21:20
01jean01
JeanRCA

Remerci Gilletarom,

Quand je regarde le détails des packages inclus dans le PPA, je vois la version 1.6 de oeSenc. Cette dernière ligne de commande doit me permettre de n'installer que lui (il n'y a plus qu'a trouver le ZZZZ qui va bien). MERCI

Comme je tiens à ma nuit, je n'essayerai que demain

dimanche 04 février 2018 21:28
Avatar_gilletarom
Gilletarom

ZZZZ, c'est le nom du plugin. Comment s'appelle-t-il dans la liste des packages inclus .....

dimanche 04 février 2018 22:30
01jean01
JeanRCA

Tout marche impec.

Merci Gilletarom, tu m'a permis de comprendre les PPA.

Dans mon cas, c'était encore plus simple: les commandes sont encapsulées par Openplotter dans un menu "mettre à jour OpenCPN / Plugin". Cela émet les deux commandes évoquées plus haut

lundi 05 février 2018 21:56
Yves_portrait
Yvec

Bonsoir JeanRCA,
Je suis en train de faire avec 3 mois de décalage la même instal que toi... mais j'ai un RPI3B+, le dernier né, avec Debian 9 "Stretch"... or je suis en train de réaliser qu'Openplotter n'est pas compatible avec cette config... Sur quel RPI as tu fais ton installation : PI3B ou PI3B+?
Je suis complétement néophyte et découvre cet univers linux en tatonnant!

mardi 15 mai 2018 21:35
Pavillonbleuocc
a_guy

Slt Yvec

fais une recherche sur le site (ici) pour l'Install d'open plotter il y a plusieurs fils qui traite de ce sujet . Mais en gros tu refais une installe complète en mode noobs (debutant) d'open plotter et c'est tous . un peut comme tu as installé ton Stretch

http://www.sailoog.com/blog-categories/openplotter-rpi

reviens sur un des posts si tu bloque quelques part !

A+

mercredi 16 mai 2018 15:48 *** Message modifié par son auteur ***
Yves_portrait
Yvec

Salut a-guy, merci pour ton message.
En réalité OpenPlotter V0.10.0, Noobs ou pas noobs ne fonctionne pas sous debian 9 (aka Stretch) et le nouveau Rpi 3B+ disponible depuis deux ou trois mois en remplacement du 3B.

Je viens d'avoir une réponse de Sailoog, le créateur d'OpenPlotter qui me confirme la sortie imminente de la version V1.0 d'OpenPlotter (normalement le 1/06). Cette version sera largement améliorée et notamment compatible avec le 3B+ (dixit Sailoog : "Lot of work has been done on it. moitessier hat support, RPi3+ support, Signal K full implementation, autopilot, new wifi management, new serial management...")

Il me confirme aussi la sortie du Moitessier Hat (https://www.rooco.eu/), un petit pas pour l'homme mais un pas de géant pour la navigation électronique

jeudi 17 mai 2018 08:23
Pavillonbleuocc
a_guy

reSalut Yvec

j'ai un RPI3B pas de + et il tourne sur openplotter v0.10 .
effectivement ce n'est pas Stretch mais Jessie .Mais je dirais ''cela ne nous regarde pas ''.
Contrairement a une installation standard sous Windows où on vient rajouter une couche logiciel ,je dirais que l'installation via openplotter est ''clés en mains '' . donc il pourrait tourner sur Marshmallow ou Fedora pour l'utilisateur final peut importe !

Maintenant si tu veux faire tourner sous ton Stretch openCPN c'est une autre histoire mais ce n'est pas openplotter (c'est openCPN).

j'ai aussi fait un post pour faire une installe (compil) je chercherais cette AM )d'openCPN sous Stretch .
Quelle erreur as tu lors de l'installe !

A+

A_guy

jeudi 17 mai 2018 09:26 *** Message modifié par son auteur ***

Répondre

Pour participer aux forums, vous devez être inscrit et identifié

Vous identifier | Créer un compte matelot

Retour forums