Tous les forums > HEO Clubs > Raspberry pi + Garmin 172c
Imag0097
28marc28

Raspberry pi + Garmin 172c

Bonjour à tous,

Je rencontre un problème entre opencpn V4 et mon raspberry pi.

En effet, je viens de créer ma carte de conversion TTL<->CMOS pour le transfert des données.

Je récupère bien mes trames du GPS au rap.

En revanche, impossible d'envoyer une route ou un point, du rasp au GPS.

A la sortie du rasp je ne vois pas de trame sortir avec un oscillo ....
J'utiliste une route envoyer au GPS et la rien ....

Savez-vous ce qu'il faut configurer sur le rasp ou opencp, pour qu'il envoi les trames.

Je precise que j'utilise bien sur le même port que pour la réception, à savoir /dev/ttyAM0.

Par avance merci de vos réponses.

28marc28

dimanche 26 juillet 2015 21:20

Liste des contributions

Lauben_bmr_83x110
BMayer (LauBen)

Je crains que les appareils Garmin nécessitent un protocole propriétaire. J'ai un 152, et l'envoi des données nécessitent des outils spécifiques

dimanche 26 juillet 2015 22:15
Imag0097
28marc28

Bonjour bmayer,

merci pour ta réponse, ca m'étonne Opencpn traite le format Garmin normalement.

28marc28

mardi 28 juillet 2015 08:48
Avatar
Swanee

C'est un peu hors sujet sur un forum de voileux, mais bon...

Si tu as déjà vérifié l'absence de signaux à l'oscillo en sortie du GPIO, il faut déjà lever le doute concernant le matériel.
Fais un test simple d'envoi de données sur ttyAM0 en dehors de OpenCpn (avec ioctl par exemple) et verifie que l'oscillo s'agite.

Sinon, ne pas oublier que le GPIO, s'est de la sortie TTL...

dimanche 26 juillet 2015 22:50
Imag0097
28marc28

Bonjour Swanee,

et merci pour ta réponse.

En fait j'ai fait des tests du style cat lfkjdlkfjsjf > /dev/ttyAMA0

L'oscillo s'affole, j'ai bien un signal qui passe.

C'est avec openCPN que cela ne sort pas.

J'ai peut être un erreur de config sur opencpn pourtant j'ai un peu tout essayé.....

Pour le TTL, pas de souci, j'ai réalisé sur platine un convertisseur TTL CMOS bidirectionnelle.

28marc28

mardi 28 juillet 2015 08:45
Missing
Zuod

J'ai un gps 152. Je l'ai connecté sur un port usb du pi2, sans carte de connexion. Pas de problème pour la position (ça marche mieux qu'avec l'eepc).
Pour transferer des WP, idem: ça marche impeccable, sans avoir besoin de configurer le gps en mode transfert (c'était nécessaire avec l'eepc).
Pour les routes, c'est (un peu) moins bien. Je n'arrive à up-loader que les WP de la route, pas la route elle-même. Mais ça me suffit pour l'instant.

lundi 27 juillet 2015 09:33
Imag0097
28marc28

Bonjour Zuod,

Merci pour ta réponse.

Peux-tu n m'indiquez la config opencpn et gps que tu as utilisé ?

Par avance merci.

28marc28

mardi 28 juillet 2015 08:46
Missing
Zuod

J'ai fait exactement ça:
http://www.cruisersforum.com/forums/f134/raspberry-pi-2-a-142824.html
Ayant eu quelques soucis avec des cartes SD, j'ai refait la manip à plusieurs reprises. Pour l'une d'elles, il y a eu un bug: impossible de configurer les ports com dans opencpn. J'ai reformaté et tout réinstallé, et plus de bug.
Pour le gps, ça marche avec presque toutes les configs, contrairement à avant, avec le pc, où j'avais passé du temps à trouver la bonne.
Pour info, j'ai aussi l'AIS avec la vhf navicom rt650, sur l'usb du RPI. Nickel.

mardi 28 juillet 2015 09:58
Stf_10
gwalarnovni

Bonjour,
Je suis entrain d'installer un rpi avec open cpn. Je n'arrive pas à capter le signal gps.
Ma config actuelle:
- bateau alu
- un vieux pc avec windows XP et open cpn
- vhf navicom RT550 DSC, antenne GPS à l'extérieur
actuellement le signal de l'antenne qui fournit la position à la vhf est aussi utilisé pour le pc via une connexion 9 broches RS 232 et fournit la posiiton pour opencpn. Tout marche bien.

Sur le RPI open cpn marche très bien sauf le signal gps.

J'ai rajouté une rallonge RS232/ USB pour connecter au RPI mais pas d'info de position sur le RPI.

Les utilisateurs de RPI/OpenCpn pourraient ils me donner quelques directions ou chercher !! Merci.

Pour info, l'écran est un EYOYO 12" sur 12 V. Très bien.


samedi 15 juin 2019 18:05
Missing
poba

bonjour gwalarnovni
si tu ne l'as pas deja fait, tu peux verifier dans un terminal si ton gps fonctionne en tapant cgps, si rien, voir installer le gps en tapant
sudo apt-get install gpsd gpsd-clients python-gps
reboot et relance cgps
si rien revoir les connexions si fonctionne voir les connexions opencpn ?

samedi 15 juin 2019 20:15
Stf_10
gwalarnovni

Merci poba, je teste chez moi "a sec" dans 1 semaine puis debutjuillet sur le bateau.

mercredi 19 juin 2019 18:46

Répondre

Pour participer aux forums, vous devez être inscrit et identifié

Vous identifier | Créer un compte matelot

Retour forums