Tous les forums > Equipements > OpenCpn ne veut pas créer le fichier d'identification pour Oesenc
Missing
1180michel

OpenCpn ne veut pas créer le fichier d'identification pour Oesenc

Bonjour à vous !
Tout est dans le titre : sous Win10, opencpn 4.8.8 n'arrive pas à créer le fichier d'identification nécessaire pour pouvoir utiliser les cartes OesEnc. Il me dit "erreur lors de la création du fichier" etc... "Voir Opencpn.log". Dans ledit .log, je ne vois rien qui m'éclaire.
Deux choses :
1) Ca a très bien fonctionné sous XP
2) Le fichier d'installation du plugin s'appelle oesenc_pi-2.4.0-win32.exe. Je suppose que ça ne marchera pas si on est en 64 bits... Or, je ne vois nulle part d'autre fichier d'installation du plugin, genre "win64.exe".
Est-ce sans espoir ?
Merci à vous,
Michel de Nieuport.

lundi 11 mars 2019 16:40

Liste des contributions

Avatar_gilletarom
Gilletarom

@1180Michel,

A la question "Est-ce sans espoir ? ", la réponse est évidemment Non !

Une première partie de la réponse : 32 bits ou 64 bits, dans tous les cas OpenCPN et ses plugins, et en particulier oeSENC fonctionnent toujours.

Et des questions :

Une première question préalable : la machine sous W10 était-elle-sous W XP préalablement ? autrement dit avez vous fait une mise à jour du système d'exploitation du PC ?

Seconde question préalable : Vous dites que oeSENC ne fonctionne pas.

- Vous l'avez donc théoriquement installé. Apparait il dans les "Options/Compléments" ?

- Avez vous un message qui s'affiche à l'ouverture des "Options/compléments", message vous disant qu la version que vous avez n'est pas adaptée à O4.8.8 ?

lundi 11 mars 2019 17:01
Missing
1180michel

Merci Gilletarom pour cette réponse rapide !
Le PC est neuf, et Win 10 (family) était installé d'origine.
OESEnc fonctionne : le plugin est bien installé, pas de message d'erreur. Je clique sur le plugin, je vais dans "préférences", et je clique sur "Créer le fichier d'identification du terminal". Il réfléchit 5 secondes et puis j'ai un message encadré titré "Message du complé..." et disant : "Error creating Fingerprint File. Check Opencpn log file".
Comme c'est en anglais, serait-ce une erreur sytème plutôt qu'une erreur Opencpn ?
J'ai essayé en démarrant OC comme administrateur, ça ne change rien. J'ai rebooté plusieurs fois, ça ne change rien...
Merci de l'intérêt et à plus tard !
Michel de Nieuport.

lundi 11 mars 2019 17:31
Avatar_gilletarom
Gilletarom

@1180Michel,

Pouvez vous envoyer le fichier opencpn.ini et le fichier opencpn.log. Ils sont accessibles en allant dans l'aide . Pour cela il faut cliquer sur le bouton bleu "?".

D'autre part, avez vous d'une manière ou d'une autre pris contact avec l'éditeur de cartes marines vectorielles O-Charts ?

lundi 11 mars 2019 22:20 *** Message modifié par son auteur ***
Bd-kran-003
1
Tdr

Bonsoir,

Juste au cas où... il n'y a que 2 activations/fingerprint possible par achat !!

lundi 11 mars 2019 22:37
Missing
1180michel

Bonjour tous !
@gilletarom : voici les fichiers demandés, merci pour l'aide
Je penche pour une erreur genre Win10 qui ne veut pas écrire à l'emplacement voulu par Opencpn, ou qqch comme ça. J'ai lancé OC en tant qu'administrateur, ça ne va pas, j'ai réglé les permissions d'écriture sur C: au maximum, ça ne va pas, j'ai réinstallé OC sur le disque E:, ça ne va pas... Dur dur, la plaisance

@tdr : le problème n'est pas au niveau de l'activation, mais au niveau de la génération du fichier d'identification par opencpn sur ma 2ème machine...

Michel de Nieuport

mardi 12 mars 2019 11:57
Avatar_gilletarom
Gilletarom

@1180Michel,

Bien reçu ... Je vais voir si j'arrive à en tirer quelque chose. Sinon, je ferai appel à plus compétent que moi.

En attendant :

Il m'est venu une question : Vous dites que votre PC est neuf. J'en déduis qu'il n'est peut être pas à jour de la toute dernière version de W 10. Suis je dans l'erreur ?

Dans tous les cas, pouvez vous me trouver la version exacte de W10 que vous avez ?
(Pour savoir exactement quelle version, ouvez les paramètres de W10, puis "Système" puis, tout en bas de la page "Informations système". il suffit alors de parcourir la page , tout y est écrit.)


Je suis sans doute un peu trop curieux. Veuillez m'en excuser. Je vous avais demandé ceci :
"
D'autre part, avez vous d'une manière ou d'une autre pris contact avec l'éditeur de cartes marines vectorielles O-Charts ?
"
Vous pouvez me répondre par MP,ici sur H&O.

mardi 12 mars 2019 16:32 *** Message modifié par son auteur ***
Avatar_gilletarom
Gilletarom

Et dernière idée mais pas stupide ...

Il arrive que l'antivirus empêche oeSENC de travailler ... il faut que le logiciel oeserver,, inclus dans le plugin oeSENC, puisse communiquer avec O-Charts.

Donc, avez vous cherché de ce côté la ?

mardi 12 mars 2019 18:01
Avatar_gilletarom
Gilletarom

Rien selon moi dans les fichiers ne permet de comprendre. J'ai donc fait remonter vos fichiers jusqu'au bon dieu et à ses saints. Même constat venu d'en haut ... Deux pistes sont envisager.

Je ne parle ici que de la première que j'avais déjà spontanément indiquée : Désactiver l'antivirus et ré-essayer.

Pour ce qui me concerne, j'utilise l'antivirus Windows Defender fourni par Microsoft avec Windows 10. Il semble qu'il fasse bien son travail.

Pour la seconde piste, on verra après.

mercredi 13 mars 2019 09:37
Missing
1180michel

Merci Gilletarom, mais je crois de plus en plus que c'est une protection en écriture de Win 10. Où OC écrit-il le fichier d'identification ? Si c'est dans c:\ (dans le root) le problème peut provenir de là.
Je creuse, nouvelles suivront...

mercredi 13 mars 2019 12:43
Avatar_gilletarom
Gilletarom

@1180Michel

D'un part, récemment, il y a eu un cas de non création du fichier FPR du à l'antivirus, d'où mon idée. Donc, quand même dite moi si vous avez testé en ayant arrêté l'antivirus ? Quel antivirus utilisez vous ?

D'autre part, si le fichier est créé, sa création est attestée dans le fichier log or, le fichier log n'en parle pas. Donc, à priori, le fichier n'a pas été créé.
S'il l'avait été vous auriez un fichier sur le bureau du PC.

mercredi 13 mars 2019 21:19
Missing
1180michel

Problème résolu !!! J'ai lancé Win10 en mode sans échec, ça a débloqué l'écriture sur c:\ (root) et j'ai pu avoir mon fichier d'identification... Donc, c'était peut-être bien un des antivirus (j'emploie Comodo), en tous cas il y avait une impossibilité d'écrire dans le root de C:\, et c'est ça qui bloquait. C'était pas la faute à OpenCpn
Merci à Gilletarom et tous les autres, et ne vous envolez pas aujourd'hui, ça va encore souffler grave !
Michel de Nieuport

jeudi 14 mars 2019 11:09
Avatar_gilletarom
Gilletarom

Voila une bonne nouvelle.

Je suppose que maintenant vous allez acheter des cartes oeSENC chez O-Charts.

Si vous continuez à avoir des difficultés en faisant l'installation des cartes (et sans utiliser le mode sans echec) revenez nous le dire.

jeudi 14 mars 2019 11:28
Img_20180618_163612
juliusse

Au fait @Gilletarom, tu as vu mon post, Sailoog m'a confirmé la sortie prochaine du dongle oesenc.
https://www.hisse-et-oh.com/forums/equipements/messages/2505587-open-cpn-et-cartographie-osenc#reply_2507816

jeudi 14 mars 2019 14:02
Missing
1180michel

@Gilletarom : les cartes étaient déjà achetées, je les avais installées sans problème sur mon PC de bord, et les voilà maintenant sur mon PC domestique.
Donc, tout baigne !
Michel de Nieuport

jeudi 14 mars 2019 18:03
Avatar_gilletarom
Gilletarom

@1180Michel,

Comment ça "Tout baigne" ? Une voie d'eau ce serait elle déclarée à bord ...

En tout cas, bravo à vous d'avoir trouvé la solution.

vendredi 15 mars 2019 09:20 *** Message modifié par son auteur ***

Répondre

Pour participer aux forums, vous devez être inscrit et identifié

Vous identifier | Créer un compte matelot

Retour forums