Tous les forums > Equipements > OpenCPN et NMEA
Missing
sauvage 22

OpenCPN et NMEA

Bonjour
J'ai voulu faire communiquer OpenCPN et mon capteur de tête de mat.
l'idée était d'avoir sur le tableau de bord le vent vrai et le vent apparent
Open CPN reçoit bien les phrases MVM VWR VWT et VPW mais me les indique comme filtrées et refusées Quelqu'un a-t-il une idée sur la question ?

mardi 07 novembre 2017 16:45

Liste des contributions

Gwenhadu
AISEAG

Tu ne nous en dis pas assez : Version?, OS?

mardi 07 novembre 2017 17:48 *** Message modifié par son auteur ***
Missing
sauvage 22

OpenCPV 4.6 Windows 10

mardi 07 novembre 2017 17:50
Avatar_gilletarom
Gilletarom

@Sauvage22,

Pouvez vous nous montrez une copie d'écran de la connexion que vous avez établi ?

Et aussi, quel est le modèle du capteur de tête de mat ? Et comment s'effectue le transfert de données ?

mardi 07 novembre 2017 20:33 *** Message modifié par son auteur ***
Missing
sauvage 22

@Gilletarom
capteur ADVANSEA
Transfert des données GPS sur ordinateur par miniplexeur Miniplex 3
Sur OpenCPN les phrases GPLL GPGGA GPGTG GPRMC passent bien en entrée et sortie
MWV VWR VWT VPM GPZDA sont indiquées comme filtrées et refusées

mercredi 08 novembre 2017 10:09
Pavillonbleuocc
a_guy

Tu n'as pas la possibilités de les rajoutés ? ! dans le menu paramètre connexion - modifier il s ouvre une fenêtre et normalement on peut les rajouter ! avec les trois petits point (de mémoire je ne suis pas devant opencpn )

mercredi 08 novembre 2017 10:27 *** Message modifié par son auteur ***
Missing
sauvage 22

@a_guy
Je l'ai fait mais les phrases existent bien mais sont refusées

mercredi 08 novembre 2017 10:44
Pavillonbleuocc
a_guy

c'est quoi ces trames ? MVM VWR VWT et VPW ?

j'ai trouve ça pour SeaTalk

Angle de vent apparent
MWV, VWR
Vitesse du vent apparent
MWV, VWR
Portant à Waypoint
BWC, APB
Parcours au sol (M)
VTG
Erreur de suivi de piste
APB, XTE
Rendez-vous amoureux
ZDA
Profondeur
DBT
Distance (Log)
VLW
Distance (voyage)
VLW
GPS Fix / Pas de correction
GGA, GLL
GPS HDOP
GSA, GGA
GPS PDOP
GSA
GPS Azimut par satellite
GSV
Altitude du satellite GPS
GSV
Numéro de PR par satellite GPS
GSV
GPS SNR par satellite
GSV
ID de station différentielle GPS
GGA
Différentiel GPS AGE
GGA
GPS Nombre de satellites
GGA
Hauteur de l'antenne GPS
GGA

sinon sur open cpn dis lui de refuser ...... rien ( ignorer les phrases) et tu laisse en blanc (filtre a l'envers )

mercredi 08 novembre 2017 13:07 *** Message modifié par son auteur ***
Missing
sauvage 22

MWV vitesse et angle du vent
VPW vitesse mesurée parallement au vent
VWR VWT : je n'ai pas trouvé Phrases générées par le capteur Advansea

mercredi 08 novembre 2017 13:56
Pavillonbleuocc
a_guy

Oui mais ce n'est pas les phrase noté plus haut ?
: MVM VWR VWT et VPW !!! c'est pas ça l'erreur ?

mercredi 08 novembre 2017 14:03
Avatar_gilletarom
Gilletarom

@Sauvage 22

D'une part, les phrases NMEA acceptées par OpenCPN sont décrites dans cette page :
http://opencpn.fr/__OpenCPN_Dossier_technique/8_Dossiers_techniques/DT_31_NMEA/DT_31_NMEA.htm

D'autre part, toutes les phrases que vous citez font partie de la liste. Donc, vous devriez les voir toutes non refusées.

Mais, certaines sont refusées. Je pense que l'explication tient au fait qu'elles ne sont pas dans la liste des phrases que OpenCPN gère "spontanément". Je veux dire par là que certaines phrases sont théoriquement acceptées mais pas "spontanément" en pratique. De mémoire, ce genre d'aberration a déjà été décrite sur H&O.

La solution qui me vient à l'esprit consiste à les ajouter en entrée dans le filtre. Mettez un filtre en entrée qui contiendra toutes les phrases que vous voyez déjà et ajoutez y celles que vous voudriez y voire.

Eventuellement, voyez dans cette page comment on ajoute des phrases dans un filtre :
http://opencpn.shoreline.fr/__OpenCPN_PC/2_Configurer/CFG_13_A_Options_Connexions_Windows/CFG_13_A_Options_Connexions_sous_windows.htm

Et si ça marche revenez nous le dire, sinon, on cherchera une autre solution.

mercredi 08 novembre 2017 19:50 *** Message modifié par son auteur ***
Missing
sauvage 22

J'avais bien tenté de rajouter un filtre mais celui ci n'apparait plus dans la fenétre (erreur de manip ?) d'autre part la "vraie phrase" commence par II (IIVWR et non VWR) je vais réessayer avec un nouveau filtre

jeudi 09 novembre 2017 10:16
Avatar_gilletarom
Gilletarom

@Sauvage22 :

Si la phrase commence par IIVWR, vous avez la possibilité d'ajouter "IIVWR" comme phrase à faire accepter. Et si ça marche pas, il me semble que vous pouvez entrer aussi "**VWR" (mais ça j'ai jamais testé).

jeudi 09 novembre 2017 17:33
Missing
1
sauvage 22

@Gilletarom
Je viens de faire des essais en créant des filtres IIVWR etc.... (et pas VWR tout court !) cela fonctionne et mes données aérien sont utilisables sur le tableau de bord.
Autre probléme: le répétiteur NASA clignote lorsque on veut utiliser une route sur OpenCPN alors que le pilote les accepte, peut étre aussi un probléme de filtre ?

jeudi 09 novembre 2017 17:32
Avatar_gilletarom
Gilletarom

@Sauvage 22

Oups ... J'avais pas lu ce post !!!! Désolé d'avoir rédigé le post précédent inutilement. Donc, bravo si vous avez solutionné votre galère.

Ou plutôt, presque inutilement. Je voudrais, si vous le voulez bien, que vous testiez votre filtre en remplaçant "IIVWR" par "**VWR". Dites nous ici si cette autre solution fonctionne ? Merci d'avance.

Concernant le problème du répéteur NASA : En première réaction, je sèche. Il faut dire que je n'ai pas ce matériel sur mon bateau.

Ceci dit, que voulez vous dire par "le répétiteur NASA clignote lorsque on veut utiliser une route sur OpenCPN " ? Plus précisément, qu'entendez vous par "Utiliser une route sur OpenCPN" ?

jeudi 09 novembre 2017 17:47 *** Message modifié par son auteur ***
Missing
sauvage 22

@Gilletarom
J'avais essaye "VWR" mais sans résultat -peut étre une erreur de manip
Le répétiteur clignote: les indications sont justes 1 sec sur 2 et écran blanc 1 sec sur 2
Utiliser une route: je choisis une route dans le gestionnaire de routes, je la valide et je clique sur "activer". Elle apparait sur Open CPN, sur les indications du pilote et du répétiteur

vendredi 10 novembre 2017 09:35
Avatar_gilletarom
Gilletarom

@Sauvage22 :

Deux questions, je réponds avec deux posts différents.

1° Au sujet de "VWR" :

J'avais bien vu que vous aviez essayé "VWR". Et je n'avais pas été surpris du fait que cela ne "marchait" pas. En effet, il manquait les deux premières lettres qui servent à définir le nom de l'appareil émetteur.

Pour comprendre, je vous propose un cas d'école avec un bateau possédant deux appareils, de marque différente, donc provenant de deux fabricants différents, et fournissant tout les deux les données contenues dans les phrases VWR.

En premier, il faut savoir qu'aucun des deux appareils n'envoie la phrase "VWR". Mais par exemple, le premier envoie la phrase "XXVWR" et le second la phrase "YYVWR". "XX" et "YY" sont les deux lettres permettant de reconnaitre les nom des fabricants.

Dans le PC, OpenCPN voit passer les deux phrases. Si vous créez une connexion en entrée :
- avec le filtre "Accepter la phrase VWR", vu qu'il n'y a pas de phrase VWR qui passe, OpenCPN ne prendra en compte ni "XXVWR", ni "YYVWR".
- avec le filtre "Accepter la phrase XXVWR", OpenCPN prendra en compte seulement la phrase "XXVWR" et pas l'autre. Pour autant, cela ne signifie ra pas que le second appareil soit en panne.
- avec le filtre "Accepter la phrase YYVWR", ce sera la situation symétrique.

VOILA POURQUOI, je vous demande, si vous avez quelques minutes à perdre, de faire un test supplémentaire : Créez en entrée, un filtre qui est "Accepter la phrase "**VWR". Je place les étoiles volontairement à la place de "II". Je veux vérifier que dans ce cas, vous verrez quand même défiler, dans les phrases acceptées, la phrase "IIVWR"

Merci d'avance.

vendredi 10 novembre 2017 10:53 *** Message modifié par son auteur ***
Avatar_gilletarom
Gilletarom

@Sauvage22 :

2° Au sujet des routes.

Attention, lisez au préalable, si l'anglais ne vous rebute pas, cette page web :
https://opencpn.org/wiki/dokuwiki/doku.php?id=opencpn:opencpn_user_manual:connections
Sinon, en voici une tentative de traduction :
http://opencpn.fr/__OpenCPN_PC/2_Configurer/CFG_13_A_Options_Connexions_Windows/OpenCPN Connexion_V.O_2_T.html
Tout ceci est repris dans cette autre page :
http://opencpn.fr/__OpenCPN_PC/2_Configurer/CFG_13_A_Options_Connexions_Windows/CFG_13_A_Options_Connexions_sous_windows.htm

Bien comprendre que le transfert de données vers le pilote ne dépend pas des connexions que nous mettons en place dans la page "Options/Connexions". (Quoique, peut être, dans certains cas, avec certains matériels .. Mais je ne sais lesquels.)
Le transfert de données se fait de la façon suivante :
- Créer une nouvelle route ou charger une route dans le gestionnaire de route en la laissant visible
- Activer la route
- Placer la souris sur la route pour faire apparaitre le menu contextuel des routes
- Choisir la commande "Envoyer au GPS (Série)"

Notez aussi que , dans la version 4.8 d'OpenCPN, il y a une seconde commande "Envoyer au nouveau GPS" (En anglais, "Send to new GPS"). Faute d'avoir expérimenter, je ne sais ce qu'il faut penser de cette seconde commande. Donc, à vous de tester et si vous le voulez bien, rapportez ici vos résultats, en particulier en testant lorsque vous êtes en nav.

Et j'ajoute encore "Merci d'avance".

vendredi 10 novembre 2017 10:51
Avatar
Mobilis

De mémoire OPENCPN envoie des trames RMC en sortie (vers le NASA).
Je pense que les trames xxRMB provenant du GPS sont aussi ré-envoyées.
Le NASA reçoit donc les deux trames presque simultanément mais avec la xxRMB qui n'a pas les information de route.
Essayes de filtrer les trames xxRMB venant du GPS afin qu'elles ne repartent pas sur la sortie "autopilot".
xx est un préfixe qui peut changer suivant les équipement. Vérifie dans la valeur dans l’afficheur des trames NMEA.

Franck.

jeudi 09 novembre 2017 18:46
Missing
sauvage 22

@Mobilis
J'avais eu le même probléme, il y a quelques années avec un traceur en plus du GPS, j'avais intercalé un inter sur le circuit. je pensais étre à l'abri du probléme en utilisant un multiplexeur..sans résultat! Le NASA a besoin des trames RMB RMC et GSA il me semble qu'en filtrant RMB, l'affichage est stable mais incomplet

vendredi 10 novembre 2017 09:52
Avatar
Mobilis

J'ai répondu de mémoire dons j'ai un petit doute sur que j'ai écrit.
Par contre je suis sur que le problème tourne autour de ces deux phrases car j'ai déjà eu le problème.
Je regarderai ma config ce weekend pour te le confirmer.

Franck.

vendredi 10 novembre 2017 11:21
Avatar
Mobilis

J'ai regardé mon paramétrage d'OPENCPN est la configuration des phrases envoyées vers le NASA est la suivante :
- ECRMB afin d'envoyer les informations de navigation provenant d'OPENCPN (préfixe EC) au NASA.
- GPRMC afin d'envoyer les informations de cap et vitesse du GPS FURUNO (préfixe GP) au NASA quand une route n'est pas active. OPENCPN ne créant ces propres trames uniquement que lorsqu'une est active, si on ne le fait pas, il n'y a plus d'indication sur le NASA si une route n'est pas activée.
Dans cette configuration, une route suivie à partir du GPS ne fonctionnera pas. Il faudrait envoyer xxRMB, mais attention il faudra avoir une route GPS OU OPENCPN sinon il y aura des conflits d'affichage et des risques que la mauvaise route soit suivie.
Si ton port sortant à besoins d'autres informations (pilotes...) il faudra rajouter les rajouter aux phrases envoyées.
J'espère que j'ai été clair et que ça résoudra ton problème.

Franck.

samedi 11 novembre 2017 18:54 *** Message modifié par son auteur ***
Missing
sauvage 22

@Mobilis
Je viens de regarder ma configuration: J'ai bien les phrases RMB,RMC GSA mais sans les prefixes je vais essayer de modifier cela. Merci

lundi 13 novembre 2017 09:46
Avatar_gilletarom
Gilletarom

@Sauvage22

J'ai vu l'autre fil avec le shéma de cablage. Je pense que ce shéma n'y est pour rien. Si des phrases arrivent et sont acceptées et d'autres arrivent et sont refusées, c'est pour la raison que j'ai proposée dans le post précédent. Mais, j'ai encore un doute.

mercredi 08 novembre 2017 19:43 *** Message modifié par son auteur ***
Lauben_bmr_83x110
bmayer

D'après le schéma http://hisse-et-oh.com/forums/equipements/messages/2233336-opencpn-nmea-bis
Je comprends que l'aérien est nativement un équipement qui délivre du NMEA, puisque cet aérien est connecté directement au multiplexeur.

Ai-je bien compris ?

mercredi 08 novembre 2017 11:14
Missing
sauvage 22

oui bien compris

mercredi 08 novembre 2017 13:45
Logo_baleinoid
MOBY

Et en décochant "controle du checksum" ?

mercredi 08 novembre 2017 11:22
Missing
sauvage 22

Je vais essayer

mercredi 08 novembre 2017 13:49
Lauben_bmr_83x110
bmayer

Déjà, en connectant un ordi, directement aux fils de l'aérien, à l'aide d'un outil de type "terminal", paramétrè conformément à ce qu'attendu (4800, ...), qu'est-ce que tu reçoit ?

mercredi 08 novembre 2017 14:13

Répondre

Pour participer aux forums, vous devez être inscrit et identifié

Vous identifier | Créer un compte matelot

Retour forums